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Part 1 - Introduction and Overview

 

 

 Star Gazers

 

 

Whether you want to make your first try at UV mapping a model for texturing, or if you 
are a veteran at UV mapping with other programs, there is a new utility out there called 
Ultimate UnWrap3D that is worth checking out and it's the subject of this month's 
tutorial.  



 

 

We will start off by defining UV mapping, then take a quick look at what UnWrap3D does 
and layout a strategy for one of the ways it can be used.  Next, we will take a look at 
some of the main menus, then go to some screenshots illustrating a few of the different 
mapping modes offered.  Navigating and selecting in the 3D window will then be 
covered, followed by a quick look at how new groups can be created.  We will finish up 
with a Conclusion and with the links to the UnWrap3D website and to a tutorial stepping 
through the creation of the model of an Easter Island statue used as an example in this 
walk-through of the UnWrap3D program.

The last seven images act as links to larger versions of those images.  Just click on the 
image you're interested in, and a full size 1024 by 768 pixel screenshot should open in 
another window.  If this larger image doesn't appear at full size, then let your mouse 
hover over the image and click on the magnification button that appears.

This tutorial uses a lot of images.  To speed up the download times, it has been broken 
up into six pages.  A navigation bar is provided on the bottom of each page.  If you 
download the PDF for Adobe Acrobat, you will see that version of the tutorial is 
arranged as a single long page since downloading is not an issue.

 

 

 

UV Mapping Defined

UV coordinates are the “pins” used to attach a texture to a model.  UV mapping is the 
process of applying UV reference coordinates to a 3D model.  The two axes of the image 
are called U and V since X, Y, and Z are already commonly associated with the 3D 
mesh.  These coordinates are used as a reference that controls how a flat 2D texture 
image will be wrapped around the model.  You can choose mapping methods such as 
spherical or cylindrical that are closest to the original shape of your model but will 
probably produce some distortion.  You can also map the model on a facet-by-facet 
basis, or ‘unwrap’ the model to produce a distortion free map that is a lot harder to 
paint, unless you have a system for projection painting your textures directly onto your 
mapped models.

 

 



 

What is UnWrap3D?

UnWrap3D is a standalone program developed by Brad Bolthouse for UV mapping and 
editing on any PC with a Windows operating system.  It features a wide variety of 
mapping modes, and the ability to simultaneously display a 2D view of the UV template 
and texture map and multiple 3D views of the textured 3D model.  Nearly every menu 
option may be assigned custom keyboard shortcuts by the user.  It also allows the user 
to create new groups in a model and to quickly group a model that was imported 
without any groups.

 

 

 

Strategy for UV Mapping with UnWrap3D

(1)  Import the model into UnWrap3D.

(2)  Select the model and apply a mode of UV Mapping that gives a good general view of 
the model in the 2D window.

(3)  Apply a reference checker pattern to the model to check for distortion.  If the 
checker pattern is distorted, any texture applied will be distorted as well.

(4)  Select different parts of the model and apply the mapping mode that best fits each 
part.

(5)  Edit the positions of the UV coordinates to minimize distortion in problem areas 
where stretching or smearing occurs.

(6) Pack the UV Map to minimize the wasted space.

(7) Export the UV map for use as a template in Photoshop, or the 2D painting app of 
your choice, and paint the texture map, then import your texture map and see how it 
fits the model in the 3D window.

(8) When satisfied, export the UV mapped 3D model for final rendering in the 3D app of 
your choice.

 

 



Part 2 - Menus and Functions

 

 

The File and Edit Menus

The File menu, shown below left, has all of the usual functions for opening and saving 
files, and importing 3D models.  The OBJ, 3DS, DXF, LWO, ASC, and COB 3D formats are 
supported.  UnWrap3D also lets you generate the primitives shown in the expanded 
menu.  The Edit Menu, shown below right, covers the controls for moving or scaling the 
UV coordinates.

 

 

 



 

 

 

The 2D Tools Menu

The 2D Tools Menu is shown below.  It has some neat features like Soft Selection, which 
allow you move groups of UV points in the vicinity of the selected point much like a 
magnet tool.  Pack UVs rearranges the UV map to minimize the unused area in your 
texture map, giving the highest texture resolution for a given image map size.

 



 

 

 

The Relax UVs and Unwrap Faces Menu

The Relax UVs menu, shown below left, allows you to minimize texture distortion.  
Untangle UVs can be used to correct overlapping UV points. 

The Unwrap Faces menu, shown below right, controls the type of unwrapping algorithm 
used, how the mapping is separated, and how it is scaled.

 

 



 

 

The 3D Tools Menu

The 3D Tools Menu contains the Interactive tools, shown below left.  The Modifiers, 
shown below right, include such useful things as the ability to flip normals.

 



 

The Select and Windows Menus

The Select Menu is shown below left, and the Window Menu is shown below right.

 



 

Part 3 - Applying Reference Textures

 

Apply the Checker Pattern in the Material Editor

For the next examples, I used the Easter Island head model that I had built in Amapi for 
an earlier project.  The model was opened in Unwrap3D, selected, and a cubic map was 
applied.  To do this, the Material Editor was opened by double clicking on the Material 
listed at the right side of the screen.  Under Properties, the diffuse color was set to 
green as shown below.  

 

 



 

Under Maps, a checker pattern was applied to the Diffusion channel as shown below.  
The size of the pattern was set by clicking the Properties button in Maps > Texture Maps 
> Diffuse Map and entering 30 for the U and V directions.  Aside from the checker 
pattern, the user may also apply a bitmap image, or other texture.  However, the 
checker pattern seems to give the best visual feedback when you are trying to minimize 
distortion.

 

 



 

Part 4 - Mapping by Box, Cylindrical, and Face

 

Box or Cubic Mapping

With the model selected, click on 2D Tools > UV Mapping > Box to apply the Box or Cubic 
mapping shown below.  Click on the image to see a larger 1024 by 768 pixel version.

 



 

 

 

Splitting the Mapping Modes into Cubic and Cylindrical

The top of the statue’s head is flat and in 3 sections.  The cubic mapping mode works 
well for these parts, so we’ll separate their UVs from the rest of the model and try 
applying cylindrical mapping to the remainder of the head.  The three head top parts 
were selected and moved outside the image box, since the cubic mapping fit them very 
well.  With the three head top parts still selected, the selection was inverted and 
cylindrical mapping was applied to the rest of the model.  Axis Alignment was set to Y 
and Seam Rotation was set to 180 degrees to place the texture seam at the back of the 
head.  The cylindrical mapping was scaled down in size too allow room for the cubic 
mapped head top parts within the texture box.

The image below shows the Cubic/ Cylindrical mapped model. Click on the image to see 
a larger 1024 by 768 pixel version.

file:///C|/InternetEye/RevTemps/Tutorials/EYE3D/UnWrap3D/cubic_checker_60.jpg


 

 

 

 

Face Mapping

Face mapping is one of the few mapping modes free of distortion or overlap, but it also 
produces a template very difficult to paint over unless you have a painting program that 
allows projection painting onto a 3D model.  Programs like Deep Paint 3D, Maxon’s Body 
Paint, and TrueSpace can handle projection painting.

The image below shows the Face mapped model. Click on the image to see a larger 1024 
by 768 pixel version.

 

file:///C|/InternetEye/RevTemps/Tutorials/EYE3D/UnWrap3D/cylindrical_checker_60.jpg


 

 

 

Part 5 - Mapping by Unwrapping

 

file:///C|/InternetEye/RevTemps/Tutorials/EYE3D/UnWrap3D/face_checker_60.jpg


Unwrap Faces

The Unwrap Faces algorithm literally unwraps the model and lays it flat to produce a 
distortion free UV template.  When using this approach, it is best to select and map the 
model in several small portions to prevent overlapping UV coordinates.  This overlap 
would cause two or more areas on the model to be textured from the same area of the 
image map.  For illustration, we will look at two examples where the entire model was 
unwrapped, one with the Ruling Lines algorithm, and one with the Spiral algorithm, to 
produce overlapped UVs.  Then we will look at an example where the model was 
mapped in small sections to prevent the overlap from occurring.

The image below shows the Unwrap Faces Ruling Lines mapped model. Click on the 
image to see a larger 1024 by 768 pixel version.

 

 

 

 

file:///C|/InternetEye/RevTemps/Tutorials/EYE3D/UnWrap3D/UnwrapFaces_RulingLines_60.jpg


The image below shows the Unwrap Faces Spiral mapped model Click on the image to 
see a larger 1024 by 768 pixel version.

 

 

 

The overlap problem was fixed by splitting the model’s UV coordinates into groups, and 
then unwrapping each group separately. 

The image below shows the model mapped in small separate sections using the Ruling 
Lines and the Spiral unwrap algorithms.  Click on the image to see a larger 1024 by 768 
pixel version.

 

 

file:///C|/InternetEye/RevTemps/Tutorials/EYE3D/UnWrap3D/UnwrapFaces_Spiral_60.jpg


 

 

Part 6 - 3D Navigation, Selection, and Grouping

 

Navigating and   Selections in the 3D Window

To navigate in one of the 3D windows, hold down the Shift key and the Left Mouse 
Button (LMB) to zoom in or out, CTRL and LMB to dolly left or right and up or down, and 
LMB alone to rotate your viewpoint about the model.

To select a part of the model in the 3D window, navigate to get a clear view of all the 
vertices or facets you want to select.  Press the S key to toggle into 3D select mode.  
Now use either the rectangular marquee or the free-drawing lasso tool to make your 
selection.  If you need to remove parts of your selection, then hold down the CTRL key 
and select those parts.  If you want to add to your selection, then hold down the shift 
key and select the parts to add.  Press the S key again to return to Navigation mode in 
the 3D window.

file:///C|/InternetEye/RevTemps/Tutorials/EYE3D/UnWrap3D/UnwrapFaces_Split_60.jpg


 

 

Adding Groups to a Model

To add a new group to a model, select the faces that will belong to the group.  In the 
Scene Window at the right side of your screen, click once on the word ‘Groups’, so that 
it is highlighted.  Now press the Insert key.  A new group called ‘untitled’ will be 
created, containing all of the selected faces.  You would then right click on the word 
'untitled' and  rename the group to something more descriptive.

The image below shows the Cylindrical with End Caps mapped model where a new group 
has been created for the facets in the nose. Click on the image to see a larger 1024 by 
768 pixel version.

 

 



 

 

Conclusion

UnWrap3D is a very handy and inexpensive utility for anybody’s 3D ToyBox.

At 35 dollars US, it is very low in cost considering all the tools it provides.  When you 
alter the UV mapping, UnWrap3D shows you the effects of the changes on the model in 
real time, making the whole process a lot easier to understand.  UnWrap3D is also very 
useful for adding groups to an ungrouped model, and the selection process for grouping 
is a lot less painstaking than what you experience using the Grouping Tool provided by 
some other programs.

 

 

file:///C|/InternetEye/RevTemps/Tutorials/EYE3D/UnWrap3D/new_group_60.jpg


The Rest of the Picture 

The picture at the start of this tutorial began as an illustration showing the mesh of the 
Easter Island statue model before and after texturing.  The un-textured mesh was 
rendered in Poser.  The Cubic mapped model was rendered in Carrara Studio 2.

The texture used for the statue on the right is a tiled variation of an image of one of the 
huge Sarsen, or Standing Stones, at Stonehenge in Salisbury, England, UK.  A UK based 
artist and friend named Strike photographed the Sarsen while vacationing with his wife, 
and I processed the image through the TextureMaker program to produce a series of 
seamlessly tiled images.  My thanks to Strike for the use of his fine image.

The backdrop of stars was produced with the StarBits program, and the image was 
composited in PhotoShop.

 

 

Related Links

Ultimate Unwrap 3D

StarBits Starfield Generator

Amapi Tutorial: Building an Easter Island Statue From Photographs
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